“IllegalStateException:只有全屏活动才能请求方向

By simon at 2018-02-28 • 0人收藏 • 126人看过

我试图更新* Glide 库从 3.8.0 4.5.0 *,但我有 这个问题与recyclerview当我添加com.github.bumptech.glide:glide:4.5.0到我的Build.Gradle 文件我在recyclerview编译行中得到这个错误。

All com.android.support libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 27.0.2, 26.1.0. Examples include com.android.support:support-compat:27.0.2 and com.android.support:animated-vector-drawable:26.1.0.
我决定更新targetSdkVersion从26日到27日,它的作品,但当我 使用android 26在设备中运行我的应用程序我有这个错误和应用程序崩溃
 java.lang.IllegalStateException: Only fullscreen activities can request orientation
                                                      at com.android.server.am.ActivityRecord.setRequestedOrientation(ActivityRecord.java:2189)
AFTE有些研究发现了一个解决方案,SDK应该是26,但如果我这样做,我会的 再次回到同样的问题。
apply plugin: 'com.android.application'

android {
    compileSdkVersion 26
    buildToolsVersion '26.0.2'
    dexOptions {
        preDexLibraries = false
        javaMaxHeapSize "4g"
    }
    defaultConfig {
        applicationId "maa.myapp"
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 43
        versionName "4.1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
        multiDexEnabled true
    }
    buildTypes {
        release {
            minifyEnabled true
            shrinkResources true
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
android {
    packagingOptions {
        exclude 'META-INF/DEPENDENCIES.txt'
        exclude 'META-INF/LICENSE.txt'
        exclude 'META-INF/NOTICE.txt'
        exclude 'META-INF/NOTICE'
        exclude 'META-INF/LICENSE'
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/notice.txt'
        exclude 'META-INF/license.txt'
        exclude 'META-INF/dependencies.txt'
        exclude 'META-INF/LGPL2.1'
    }
}
android {
    configurations.all {
        resolutionStrategy.force 'com.google.code.findbugs:jsr305:1.3.9'
    }
}
dependencies {
    implementation 'com.android.support.constraint:constraint-layout:1.0.2'
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    //notifications
    compile 'com.android.support:recyclerview-v7:26.1.0'
    compile 'com.android.support:appcompat-v7:26.1.0'
    compile 'com.android.support:design:26.1.0'
    compile 'com.github.chrisbanes:PhotoView:2.1.3'
    compile 'com.android.support:cardview-v7:26.1.0'
    compile 'com.android.volley:volley:1.0.0'
    compile 'com.android.support:multidex:1.0.2'
    compile 'com.android.support:support-v4:26.1.0'
    compile 'com.github.bumptech.glide:glide:4.5.0'
    compile 'com.squareup.picasso:picasso:2.5.2'
    compile 'com.nineoldandroids:library:2.4.0'
    compile 'com.daimajia.slider:library:1.1.5@aar'
    compile 'com.google.android.gms:play-services-ads:11.8.0'
    compile 'com.google.firebase:firebase-core:11.8.0'
    compile 'com.google.firebase:firebase-messaging:11.8.0'
    compile 'com.firebase:firebase-jobdispatcher:0.6.0'
    compile 'com.vodyasov:amr:0.5'
    compile group: 'org.apache.commons', name: 'commons-lang3', version: '3.7'
    compile 'com.google.guava:guava:23.6-android'
    testCompile 'junit:junit:4.12'
    compile 'com.squareup:otto:1.3.8'
}
apply plugin: 'com.google.gms.google-services'

2 个回复 | 最后更新于 2018-02-28
2018-02-28   #1

我有类似的问题。我看到两个选项。首先是控制设备 Android O(此Android有错误“Only fullsc青少年活动可以要求 方向“),并验证你是否可以改变他们的行为,或找到一个滑翔 使用相同的版本支持库版本。如果你的问题在android上 O与AdMob一起可以检查[this 链接](https://stackoverflow.com/questionS / 46992843 /间质性-的AdMob-广告 - IllegalStateException异常,仅全屏活动,可以-R / 46995624#46995624)

2018-02-28   #2

这是Android版本8.0即API 27的问题 我通过使用下面的方法解决了在清单中添加此代码

  <activity
            android:name="com.google.android.gms.ads.AdActivity"
            android:theme="@style/AppTheme"
            tools:replace="android:theme"
            />
并在重新s / styles添加下面的代码
 <!-- Base application theme. -->
    <style name="AppTheme" parent="Theme.AppCompat.Light.NoActionBar">
        <!-- Customize your theme here. -->
        <item name="alertDialogTheme">@style/StyledDialog1</item>
        <item name="drawerArrowStyle">@style/DrawerArrowStyle</item>
        <item name="android:windowNoTitle">true</item>
        <item name="windowActionBar">false</item>
        <item name="colorPrimary">@color/primary1</item>
        <item name="colorPrimaryDark">@color/primary1</item>
        <item name="colorAccent">@color/accent1</item>
        <item name="android:actionMenuTextColor">@color/fbutton_color_pomegranate</item>

        <item name="android:textColor">@color/primary_text</item>
        <item name="android:textColorSecondary">@color/secondary_text</item>
        <item name="android:textColorPrimary">@color/primary_text</item>

        <item name="android:popupMenuStyle">@style/popupMenuStyle</item>
    </style>
注意:如果你不使用任何物品,请在res / style apptheme中移除物品 让我知道它是否对你有帮助呃!快乐的编码

登录后方可回帖

Loading...