将设备更新到iOS 11.2会破坏Xcode 9.1的支持

By simon at 2018-02-28 • 0人收藏 • 45人看过

我试图在运行iOS 11.2的设备上运行我的应用程序,并收到以下内容 错误:

无法找到设备支持的文件

这款iPhone 5s(型号A1457,A1518,A1528,A1530)运行iOS 11.2 (15C114),这可能不支持这个版本在Xcode上。 我已经使用iphone 5s(版本11.1.2),我想建立我的项目 xcode 9.1(ios 11.1)。

4 个回复 | 最后更新于 2018-02-28
2018-02-28   #1

看来,苹果向公众发布iOS 11.2而不发布Xcode 9.2(Mac App Store最新报告9.1写这篇文章的时候), 其中包括针对运行iOS 11.2的设备所需的iOS 11.2 SDK。 你应该能够r在您的设备上使用Xcode 9.2测试版,这一点 你可以从[开发者下载 页面(HTTPS://developer.appl如果您有开发者帐户,请访问e.com/download/) 编辑: Xcode 9.2现已公开发布,您可以从中下载 该[Mac App Store](https://itunes.apple.com/us/app/xcode/id497799835?mt=12)

2018-02-28   #2

Xcode 9.2终于发布了。您可以从App Store或仅更新它 在这里下载它:

2018-02-28   #3

我的MacBook上有Xcode9.2,我的Mac Mini上有8张。所以我只是复制了11.2 Device Support Developer Disk Image .dmg和.signatur从MacBook到电脑 Mac Mini。工作很好。

2018-02-28   #4

对于像我这样的新手来说,如果你收到类似这样的消息: “这款iPhone 6运行的是iOS 11.2.X,可能不支持这样 Xcode的版本。“ 这意味着你必须更新Xcode。 当我的手机在运行11.2.6时,我遇到了这个问题,我是running Xcode 版本9.0 您可以从App Store更新它,或者只是在这里下载它:

登录后方可回帖

Loading...