Wamp 服务器加载静态文件时,DEBUG 真,而不是 DEBUG 假,即使后收集静态

By simon at 2019-05-17 • 0人收藏 • 24人看过

我使用 mod wsgi 在 WAMP 服务器上部署了一个基于 django 的应用程序,并为我运行的所有静态文件提供服务Py management. py collectstatic命令。 我检查了站点是否服务良好,但静态文件只有在 DEBUG True 时才服务。 但是根据 Django's文件真将为我们应该使用的其他服务器提供开发服务器上的静态文件错误.

我还检查了之后收集的所有静态文件收集的

我不明白为什么会发生这种情况。

下面是 settings.py 文件

项目的 Django 设置。 由"Django-admin startproject"使用 Django 2.1.5生成。 有关这个文件的更多信息,请参见 https://docs.djangoproject.com/en/2.1/topics/settings/ 文件中的设置及其值的完整列表,请参见 https://docs.djangoproject.com/en/2.1/ref/settings/ 文件中的"""import os # Build paths inside the project like this: os.path.join (BASE dir,...) BASE dir os.path.dirname (os.path.dirname (os.path.abspath (file))) # Quick-start development settings-unproported For production # 参见 https://docs.djangoproject.com/en/2.1/howto/deployment/checklist/  # SECURITY WARNING: keep the secret key used in production secret! "SECRET key"# SECURITY WARNING: 不要在生产环境中调试开启时运行! 应用程序定义已安装的应用程序['olx.apps'。 'django.contrib.admin','django.contrib.auth','django.contri.contenttypes','django.contrib.sessions','django.messages','django.contrib.staticfiles','contril.thumbnail','bootstrap3',] MIDDLEWARE ['django.ware.middle.security'. 安全中间件','django.contrib.sessions.middleware。 中间件,django.com mon。 5. CommonMiddleware','django.middleware.csrf. 中间件。 认证中间件','django.contrib.messages.middleware。 1.2.1.2.2.2.2.2.2.2.2.3.3.3.2.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3. 句子太长,请短一点。 1.1.1.1.2.1.2.2.2.2.2.2.2.2.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.3.4.3. 最小长度验证器',} ,{'NAME':'django.contrib.auth.password validation。 {'NAME':'django.contrib.auth.password validation. 注意: 对于站点正常用户'olx.myLdapAuth.MyLdapAuth'将使用 admin'django.contrib.auth.backends。 将使用 AUTHENTICATION backends ['olx.myLdapAuth.MyLdapAuth','django.contrib.auth.backends。 国际化 #  https://docs.djangoproject.com/en/2.1/topics/i18n/ 语言代码'en-us'TIME zone'UTC'USE i18n True USE l10n True USE tz True # Static files (CSS,JavaScript,Images) # Static url'/ Static /'STATICFILES dirs (os.path.join (BASE dir,'olxapp / Static') ,) Static root os. path.join (BASE dir,'') MEDIA url'/ MEDIA /'MEDIA root. path.join (BASE dir,'MEDIA')

文件

从 django.contrib import admin from django.urls import include,path from django.conf.urls.static import static from django.conf import settings urlpatterns [ path ('olx /',include ('olx.URL')) ,path ('admin /',admin.site.URL) ,] URL+ static patterns (media URL,document ROOT settings.MEDIA) urlpatterns + static (static settings.STATIC URL,document ROOT. ROOT)

用于加载 Django 应用程序的 Apache httpd.conf 文件的内容

Loadfile"c: / users / chirag.soni / appdata / local / programs / python / python37 / python37.dll"LoadModule wsgi module"c: / users / chirag. Soni / appdata / local / programs / python / python / 37 / lib / site-packages / mod wsgi / server / mod wsgi.cp37-win amd64.pyd"WSGIPythonHome"c: / users / chirag. 句子太长,请短一点
1 个回复 | 最后更新于 2019-05-17
2019-05-17   #1

我解决这个问题的方法是使用斜杠\前斜线/在5. httpd.conf文件

所以最终5. httpd.conf文件应该是这样的:

Loadfile"c: / users / chirag.soni / appdata / local / programs / python / python37 / python37.dll"LoadModule wsgi module"c: / users / chirag. Soni / appdata / local / programs / python / python / 37 / lib / site-packages / mod wsgi / server / mod wsgi.cp37-win amd64.pyd"WSGIPythonHome"c: / users / chirag. Soni / appdata / local / programs / python / python37"WSGIScriptAlias /"c: / users / chirag. soni / downloads / olxapp / olxapp / wsgi.py"WSGIPythonPath"c: / users / chirag. "soni / downloads / olxapp"别名 / 媒体"c: / users / chirag。 Soni / downloads / olxapp / media /"Alias / static"c: / users / chirag. Soni / downloads / olxapp / static /"目录"c: / users / chirag。 索尼 / downloads / olxapp / media"要求所有授权 / 目录"c: / users / chirag。 "soni / downloads / olxapp / static"要求所有授权 / 目录"c: / users / chirag"。 "soni / downloads / olxApp / olxApp"Files wsgi.py 需要所有已授权的 / Files / directory

登录后方可回帖

Loading...